January 25, 2021

Unrecognized Android Device Connected to my ARRIS Router. Help?

We recently bought an ARRIS Router with ASUS Mesh system to replace the terrible equipment issued by our ISP. It works great and the App allowing me to control and view the devices is super handy. I used a network password the app said was “very strong,” and enabled all the recommended security settings.

But recently I spotted a device just called “android” that the app said was connected. I have no idea what this could be, we do not have any android devices. It also seems like “android” is possibly a name changed from something else as the “a” is not capitalized.

I used the app to block it from the network right away, thinking if it was somehow one of our devices we would notice it not working eventually. But it’s been a few days, it still appears there, and I have no idea what it is.

Can anyone help or just explain what this could be?

Leave a Reply

Your email address will not be published. Required fields are marked *

Note: By filling this form and submitting your commen, you acknowledge, agree and comply with our terms of service. In addition you acknowledge that you are willingly sharing your email address with AiOWikis and you might receive notification emails from AiOWikis for comment notifications. AiOWiksi guarantees that your email address WILL NOT be used for advertisement or email marketting purposes.

This site uses Akismet to reduce spam. Learn how your comment data is processed.